General application instability while using Firefox and Safari web browsers.
Incident Report for 123 Form Builder
Resolved
This incident has been resolved.
Posted May 09, 2022 - 07:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2022 - 06:44 UTC
Identified
Argh! It looks like we have identified an issue with our application while being used in Firefox and Safari web browsers. Different sections and functionalities are impacted. We're working on fixing it, however in the meantime you can use all your forms and data safely by using a different web browser for ex. Chrome or Edge.
Rest assured that form submissions are not impacted. Please accept our apologies for the inconvenience we are working on solving this as soon as possible.
Posted May 06, 2022 - 08:21 UTC
This incident affected: Builder.