Degraded performance for US database infrastructure
Incident Report for 123 Form Builder
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 10:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2021 - 10:38 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 14, 2021 - 10:21 UTC
Identified
Argh! It looks like we have identified an issue with US DB infrastructure We're working on fixing it, however in the meantime general usage may be affected. We will post updates as soon as we know more. Please accept our apologies for the inconvenience.
Posted Sep 14, 2021 - 10:20 UTC
This incident affected: Forms, Submissions, Notifications, Integrations, Builder, Account, and API.