Investigating issues with 123formbuilder.com Marketing website
Incident Report for 123 Form Builder
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 08:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2021 - 07:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2021 - 07:37 UTC
Investigating
Oops! We apologize for this, we are investigating an issue with https://123formbuilder.com Marketing website.
We will post updates as soon as we know more. We are very sorry for any inconvenience.

For login you can use https://app.123formbuilder.com or https://app-eu.123formbuilder.com no other systems are affected. All forms are functioning correctly
Posted Apr 19, 2021 - 07:19 UTC
This incident affected: www.123formbuilder.com.