SMS notifications are still not being sent for US numbers
Incident Report for 123FormBuilder
Resolved
At 123FormBuilder, we take data privacy and spam prevention very seriously. In this regard, we do everything possible to make sure our users and their respondents have a positive experience interacting with our platform and the services we provide.

Therefore, to prevent violations to business communication (or app to person) laws and regulations like those enforced by the TCPA (Telephone Consumer Protection Act), sending Text/SMS messages to US numbers is no longer supported using our SMS notifications functionality.

SMS notifications can still be sent to non-US numbers for a limited period of time, but the SMS notifications functionality will be deprecated starting with May 2022.

As an alternative, we suggest using our email notifications functionality or dedicated SMS messaging tools (which you can use through our Zapier integration).

We apologize for any inconvenience caused by this! Please let me know if you have any questions or concerns regarding this topic and I will make sure to help you out.
Posted Mar 10, 2022 - 12:53 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2022 - 12:49 UTC
Identified
The issue is identified, we are working with out 3rd Party provider to solve the problem. Will post further updates once there are changes in the situation.
Posted Dec 14, 2021 - 11:45 UTC
Investigating
Issue under investigation
Posted Dec 14, 2021 - 08:31 UTC
This incident affected: Notifications.