2CheckOut Payment service outage
Incident Report for 123 Form Builder
Resolved
Incident resolved. 2CheckOut fixed the root cause and all systems are operational now.

Thank you
Posted Nov 16, 2021 - 09:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2021 - 08:21 UTC
Identified
Hey there, Form Builder! We've been notified that 2CheckOut, the service provider that helps us with payments processing, is experiencing some issues with their service. Because of this some core functionalities are affected. Unfortunately 2CheckOut does not have a public status page, we will keep you updated with the progress. We are sorry for the inconvenience.
Posted Nov 16, 2021 - 07:30 UTC
This incident affected: Forms, Submissions, and Account.