Degraded performance for Forms and Submissions
Incident Report for 123 Form Builder
Resolved
Hooray! The incident was resolved and Forms and Submissions are fully functional. Thank you for your patience, sorry for any inconvenience!
Posted Dec 31, 2020 - 10:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 31, 2020 - 09:55 UTC
Monitoring
Yay! A fix has been deployed and we are closely monitoring the performance of Forms and Submissions. Thanks for your patience!
Posted Dec 31, 2020 - 09:32 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 31, 2020 - 07:23 UTC
Identified
Argh! It looks like we have identified an issue with Forms and Submissions. We're working on fixing it, however in the meantime Forms and Submissions may be affected. We will post updates as soon as we know more. Please accept our apologies for the inconvenience.
Posted Dec 31, 2020 - 04:00 UTC
This incident affected: Forms, Submissions, and Account.